Anti-aliasing fonts is really stupid

As a quick followup to this article (how to workaround the bug in Microsoft Office 2007 that breaks your fonts in Windows), I had to show someone today what I meant when I said that their laptop was set to “blurry” mode, and realised there was a quick way of testing it.

If you can’t be bothered to try it, here’s two screenshots that demonstrate precisely why I hate blurry fonts on any good-quality LCD:
blurry-windows-11.PNG

The image on the left is Windows in “blurry” mode (with forced anti-aliasing of all system fonts). The image on the right is the exact same system, just with blurring turned off. Note that the way Windows renders fonts, the title bar of the two windows looks significantly different. This is really annoying, because the left hand title IMHO looks much nicer – but that same effect isn’t applied to the rest of the window, including the menu bar, which looks awful.

Zoomed-in version to show what’s happening:

blurry-windows-2.PNG

First thing to note: yes, the image on the right looks very blocky. But … modern LCD’s (as used in all laptops, and most 17″ or greater desktop monitors) are such high resolution that the blockiness will disappear if you want it to (just increase the base font size settings for your system; Windows has this as a built-in feature, but OS X does it much, much better – it can render fonts at a correct size *independent* of your screen resolution).

Second thing to note: Windows is artificially making all text very blurry. This is really not good for your eyes, which will then try to focus continually on something that its impossible to focus on. If your eyesight is bad, of course, you may not notice the difference from everyday objects :). It’s doing it by changing the colours of the text as well, which IS noticeable to most people – black-on-white text is actually rendered as “black+red+blue text on white”. Welcome to WYSINWYG: (what you see is NOT what you get).

If you want to turn this off on a normal Windows install:

  1. Go to Control Panel
  2. Go to Display
  3. Go to the Appearance tab
  4. Click the Effects button
  5. Un-check the tickbox for “Use the following method to smooth edges of screen fonts”

If you’ve already done that, and for some reason your fonts are still blurry … either you have Windows Vista, or congratulations, you probably upgraded your copy of MS Office, or MS Outlook, and you’ve just been shafted by Microsoft – for that you need to follow the link at the start of this post.

2 thoughts on “Anti-aliasing fonts is really stupid”

Comments are closed.