Thunderbird 3: fixing the fonts

The font-settings in ThunderBird are terrible: the default settings are ugly, and the GUI is too broken to let you change them. Fortunately, if you hand-edit the config files, you *can* change the fonts, as much as you like.

Sadly, the options etc are undocumented, and easy to get wrong. Incidentally, not only does TB have *no* help or documentation (why not?), if you go to the online “knowledge base” and search for something fairly obvious like “fonts”, you get nothing – not even the usual 3-years-out-of-date result that’s normal for this app:

Picture 131

For future reference, here’s how I made my fonts go from “ugly” to “delightful”.

Changing fonts in Thunderbird 3 – theory

For reference, in case TB fixes their fonts in future, here’s what you’re supposed to do, but doesn’t quite work yet:

  1. Go to settings
  2. Go to Display tab
  3. Click on the Advanced button in the Fonts section
  4. Configure font options, per-language

In reality, here’s what happens

  1. “Western” languages (Europe, USA, etc) in TB often do not use the “Western” font settings
  2. …rather, they use the “unicode” font settings
  3. …which aren’t available in the TB GUI
  4. …and they don’t always use them as expected

Changing fonts in Thunderbird 3 – practice

There are a couple of things that DO work, and which you need to set anyway, so:

  1. go to Setttings -> Display tab -> font-settings -> “advanced” button
  2. Choose Serif or Sans-Serif (bizarrely, this is a GLOBAL setting, even though the GUI claims it is a LOCAL setting) – this will affect all other font choices
  3. *try* setting the font-sizes, I think it sets global defaults (but … looking through the config file, those “defaults” appear to be over-ridden in most places … by default)

NB: TB is … confused … when it comes to font choice. The obvious way to make a desktop app is to ask the user “which font do you want to use in place X?” (where X = “email body”, “compose window”, “menu items”, “dialogs”, etc). Windows has been doing this for more than 15 years. TB instead arbitrarily declares different parts of the app as “Proportional” or “Monospaced” or some combination of the two. Even if you tell it not to use monospaced in certain places, it mostly ignores you. It doesn’t tell you which is which, and it’s not documented, you have to work it out by trial and error.

Edit the master config file:

  1. go to Setttings -> Advanced tab -> General -> “Config Editor” button
    • NB: another bug in the GUI – that button appears to be some local setting; it’s not, its the most important part of all the “Advanced tab” settings; I’ve no idea why they hide it like this
  2. use a filter of either “.serif” (sic) or “sans-serif” depending on which fonts you want your TB to use
    • (I think you’re nuts if you use anything but sans for email, but it’s a personal choice)
  3. The two you need to set for “email bodies” are:
    • font.name.sans-serif.x-unicode
    • font.name.sans-serif.x-western
  4. The two you need to set for “GUI dialogs” are:
    • font.name-list.sans-serif.x-unicode
    • font.name-list.sans-serif.x-western
  5. The *one* you need to set (but could also set in the main GUI) is:
    • font.default.x-western

(I’m still using TB 3; I need a desktop client at the moment, and I find myself still using it. TB 3.0.4 seems to run well on OS X. It’s fast enough and with little enough RAM that it’s easy to leave running and forget about it; earlier versions of TB on OS X would kill your Mac, and had to be force-quit frequently. With this version, I keep forgetting I’ve got it running, until it sends out a Growl…)

8 thoughts on “Thunderbird 3: fixing the fonts”

Comments are closed.